Wolfmans Howlings

A programmers Blog about Programming solutions and a few other issues

Upgrading Ubuntu Gutsy to Hardy

Posted by Jim Morris on Sun Jul 13 04:32:03 -0700 2008

I did my duty and upgraded from Gutsy to Hardy, after letting Hardy settle for a while. For the most part it was painless (unlike the last upgrade to Gutsy!).

Unfortunately the sound was now broken I have a HDA-Intel AD198x Analog chip set.

Then I discovered (just when I needed it of course) that my Samsung ML-2010 USB printer didn't print anymore.

I would get this weird error...

Unable to open device hal:///org/freedesktop/Hal/devices/...

After Googling I found this, he was half right, I don't know why but it works, except that I needed to do...

sudo chmod 700 /usr/lib/cups/backend/usb
sudo chmod 700 /usr/lib/cups/backend/hal
sudo killall -HUP cupsd
sudo /etc/init.d/cupsys restart

ie both usb and hal.

That fixed it... Amazing!

Now why won't my audio work???

Ok now it does work, go figure. The only things I changed were added this to /etc/modprobe.d/alsa-base

options snd-hda-intel model=3stack-dig

and made sure that Front was checked in the mixer and turned up.

Not sure which of those fixed it though.

Posted in Linux  |  Tags ubuntu,hardy,cups  |  4 comments


  1. Hodinky said on Mon Jul 14 05:09:11 -0700 2008
    Suuuuuuper, I had the same bullshitty thing, and that's really fixed it, Im sooo glad, thank you!!! :)
  2. Lars said on Mon Jul 14 13:24:15 -0700 2008
    ... well... I was full right :)
    My hal already had these permissions without any action done by me.

  3. wolfmanjm said on Mon Jul 14 13:48:45 -0700 2008
    Yea,thanks that really saved me, except my hal was not set right so when I initially tried your suggestion it didn't work, so I got side tracked turning off apparmor, reinstalling cups etc.
    Then for some reason I wondered if the hal permissions was the problem and it was.

    I wish I knew why this worked though. I suspect it was because I upgraded from Gutsy and the permissions were set wrong there.

    Without your Blog it would never have crossed my mind to try that, what made you think of that?
  4. SteveM said on Sun Sep 14 23:30:51 -0700 2008
    Exactly the problem I had and the solution that finally fixed it! Thanks!

(leave email »)